PostGis i Open Geo Suite 4.0

Efter lite testande så verkar inte PostGis vara helt komplett installerat när man kört Open Geo Suite installationen från tidigare i veckan. Det kan vara annorlunda om man kör på Mac eller Windows, men för mig på Ubuntu 12.04 så fungerade det i alla fall inte.

Nåja, det går att fixa.

Först så skall man fixa administratörskontot.

sudo passwd postgres

Skriv in ett nytt UNIX lösenord för användaren postgres.

sudo -s -u postgres psql

Här skall användaren postgres också få nytt lösenord:

\password postgres

Skriv in ett nytt lösenord och avsluta med \q. Det är i praktiken olika användare i UNIX och postgresql, så det kan vara olika lösenord om man vill.

Redigera även filerna /etc/postgresql/9.3/main/postgresql.conf och /etc/postgresql/9.3/main/pg_hba.conf på samma sätt som tidigare (se tidigare inlägg).

För att det skall gå att skapa spatiala databaser så måste man först skapa en mall i Postgresql.

sudo -u postgres createdb template_postgis
sudo -u postgres psql -d template_postgis -f /usr/share/postgresql/9.3/contrib/postgis-2.0/postgis.sql

Kommandona ovan skapar en ny databas kallad ”template_postgis” och kör ett skript mot denna databas. Med den andra raden ovan som modell så skall även följande skript köras:

  • spatial_ref_sys.sql
  • postgis_comments.sql
  • rtpostgis.sql
  • raster_comments.sql
  • topology.sql
  • topology_comments.sql

Sedan krävs det en omstart av Postgresql.

sudo /etc/init.d/postgresql restart

Koppla upp mot databasen med PgAdminIII och anslut som användaren ”postgres” med det nya lösenordet. Förhoppningsvis så går det bra och det skall nu gå att skapa en ny databas att lagra geodata i.

Det viktiga är att den nya databasen får ett namn (douh!) och att ”template_postgis” används som just ”Template”.

Skärmbild från 2013-11-10 20:11:34

Den nu skapade databasen skall det gå att ansluta till ifrån exempelvis QGIS och OpenGeo Explorer för att ladda upp, redigera och publicera geodata med.

Även om det nu fungerar för mig att skapa och hantera data mot PostGis i QGIS, så vill inte OpenGeo Explorer riktigt vara med när det kommer till PostGis-data. Vi får se om det är tillfälligt, eller om det är jag som gjort något galet…

Annonser

Taggar:,

Kommentera

Fyll i dina uppgifter nedan eller klicka på en ikon för att logga in:

WordPress.com Logo

Du kommenterar med ditt WordPress.com-konto. Logga ut / Ändra )

Twitter-bild

Du kommenterar med ditt Twitter-konto. Logga ut / Ändra )

Facebook-foto

Du kommenterar med ditt Facebook-konto. Logga ut / Ändra )

Google+ photo

Du kommenterar med ditt Google+-konto. Logga ut / Ändra )

Ansluter till %s

%d bloggare gillar detta: