Ubuntu och QGIS

Hur är det egentligen. Fungerar QGIS med något annat än 16.04 om man använder Ubuntu?

Jag har gjort en ominstallation av en dator och valde 17.04, och då fungerar det inte alls!!

Vad är det som händer? Några fakta, tester och erfarenheter tänkte jag redovisa här.

För det första så finns det flera källor att installera QGIS ifrån om man använder Ubuntu. Inte minst om man vill använda olika versioner av QGIS, men här utgår jag från QGIS standard som är den senaste stabila versionen.

Alternativ ett är:

deb http://qgis.org/debian <release> main

Där senaste release som är tillgänglig är Yakkety (16.10).

Alternativ två är:

deb http://qgis.org/ubuntugis <release> main
deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu <release> main

Där senaste version är Xenial (16.04).

Varför skulle man välja UbuntuGis i stället för Debian? Det enkla svaret är ”GDAL/OGR”!

Med Debian får man GDAL 1.10 och UbuntuGis 2.1. Skillnaden är bland annat stödet för GeoPackage.

Nu fungerar det att använda en ”äldre” källa i en senare version av Ubuntu, men konflikter kan uppstå. Det är dessa konflikter jag har försökt jobba runt.

Ett problem är att QGIS kräver en specifik version av GDAL, medan en annan kan installeras från UbuntuGis…

Detta kan man komma runt genom att symboliskt hänvisa till den befintliga versionen (läs mer om detta).

Jag har provat att installera QGIS med UbuntuGis på Xenial (fungerar jättebra), Yakkety (struligt) och på Zesty (fungerar inte alls). Jag har även provat att uppgradera Xenial till Yakkety efter det att QGIS installerats, vilket är minst lika struligt som att installera direkt på Yakkety, men det går. Jag kan däremot inte uppgradera till Zesty än för att prova, men det innebär säkert inte mindre problem.

Nu har jag lagt ner massor med tid på att försöka lösa detta. Jag har säkert installerat Ubuntu i olika versioner tjugo gånger utan att bli riktigt klok på problemen.

Det finns saker i senare versioner av Ubuntu som jag är intresserad av, men QGIS är ganska viktigt, så vad gör man?

Det blir nog till att installera om med Xenial och låta det vara där! Det går ju att uppgradera Kernel om man bara lyckas installera 16.04 till att börja med, något som kan innebära problem på en nyare dator med Kaby-Lake eller AMD Ryzen. Kan det vara så att QGIS och ny dator (CPU) är en omöjlig kombination just nu?

Det innebär mer jobb för att uppdatera de program jag använder då de senaste programmen inte finns i Xenial, men det får gå. Vem vill exempelvis inte använda Libre Office 5.3? Det får bli ett nytt skript för installation av Ubuntu Gnome (xenial) där jag kan lägga till alla uppdateringar och tillägg.

wget https://raw.githubusercontent.com/klakar/geosupportsystem/master/config-ubuntu-gnome-xenial.sh
chmod +x config-ubuntu-gnome-xenial.sh
sh config-ubuntu-gnome-xenial.sh

Jag har även spelat in en film om installationen där mitt skript har huvudrollen. Sedan detta skrevs och filmen spelades in så har jag gjort en del uppdateringar av skriptet, exempelvis har jag lagt till Mate Welcome/Software Botique.

Advertisements

Taggar:,

Kommentera

Fyll i dina uppgifter nedan eller klicka på en ikon för att logga in:

WordPress.com Logo

Du kommenterar med ditt WordPress.com-konto. Logga ut / Ändra )

Twitter-bild

Du kommenterar med ditt Twitter-konto. Logga ut / Ändra )

Facebook-foto

Du kommenterar med ditt Facebook-konto. Logga ut / Ändra )

Google+ photo

Du kommenterar med ditt Google+-konto. Logga ut / Ändra )

Ansluter till %s

%d bloggare gillar detta: